Infiniti QX50 Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello Everyone,

So this past Saturday all of a sudden I was about to continue driving and I noticed the revs lowered probably to around (500-700 rpm), creating a shaking vibration in the engine and the car had absolutely no power at all, luckily I was close and only had to drive it a very short distance, but stepping on the gas the car would rev to about 2000 rpm and the most it would do will be 10-12 mph. Very close to where I was able to park the car the MIL light came on in the dash and shortly after that I got an email from Infiniti on this warning. It is a 2019 QX-50 it has 15k miles on it, all services completed, it wasn't the battery since I turned the car off waited for a bit and turned it back on, also the tow truck took maybe an hour to get there and it started normal once the tow truck was placing the car on the flat bed.
I haven't heard anything from the dealer, they've been working it on it a few days and say no diagnostic, I wanted to know if anyone else on this forum has experienced this before and might know what it is.

Thanks for your help!
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
UPDATE:
Dealership could not replicate the problem, they consulted with Infiniti HQ and determined the auxiliary battery was dead. (Dealer said that aux. battery controlled a lot of electrical features in the engine such as injectors) They replaced that battery and it seemed to be like normal.
2 weeks later the same issue happened, I was doing 55 mph in a highway, accelerated to pass a car and immediately car started shaking, lost power and had to get off highway. Drove through streets very slowly until the tow truck came. Car went to the dealer and they replaced a cable in the alternator and another one for an injector. Been driving it on and off a couple of days and seems normal now.
I don't drive a lot, car barely has 16k miles on it so not sure what the wear from those cables was due to. The aux. battery could've been dead since I'm at the 3rd year of ownership and batteries last less down here in South Florida.
 
1 - 2 of 2 Posts
Top