Infiniti QX50 Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello Everyone,

So this past Saturday all of a sudden I was about to continue driving and I noticed the revs lowered probably to around (500-700 rpm), creating a shaking vibration in the engine and the car had absolutely no power at all, luckily I was close and only had to drive it a very short distance, but stepping on the gas the car would rev to about 2000 rpm and the most it would do will be 10-12 mph. Very close to where I was able to park the car the MIL light came on in the dash and shortly after that I got an email from Infiniti on this warning. It is a 2019 QX-50 it has 15k miles on it, all services completed, it wasn't the battery since I turned the car off waited for a bit and turned it back on, also the tow truck took maybe an hour to get there and it started normal once the tow truck was placing the car on the flat bed.
I haven't heard anything from the dealer, they've been working it on it a few days and say no diagnostic, I wanted to know if anyone else on this forum has experienced this before and might know what it is.

Thanks for your help!
 

·
Registered
Joined
·
3 Posts
Wowww 😳 not good at all sounds like computer brain I same issue but in 2017 Nissan Murano platinum after that I traded it in but fast forward too now I have 2019 QX50 essential preowned it had 13,000 miles when I got it right now I have 68,300 miles not issue at all I do a lot expressway driving, 🤔 only thing I done so far is brakes on front plenty of power for 4 cylinder I have factory 19” wheels but update me on what they find dealership 🥺 usually if I have issue with vehicle I trade it back in for something else 🤣
 
1 - 2 of 2 Posts
Top