Infiniti QX50 Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
My car click is 7/8 hours behind, depending on time of year, and can't be adjusted. Infiniti claims it's a rare problem and there isn't a fix for it. Anyone else have this issue? Any suggestions?
 

·
Registered
Joined
·
3 Posts
I am also having the same issue. My clock is 4 hours ahead. The "Manual time adjustment" is grayed out. Occasionally my radio station presets change then the next time I use the car they are back.
Did you have the wireless car play upgrade?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
I am also having the same issue. My clock is 4 hours ahead. The "Manual time adjustment" is grayed out. Occasionally my radio station presets change then the next time I use the car they are back.
Did you have the wireless car play upgrade?
Yes... my manual time adjustment is also grayed out. Even more surprising is Infiniti doesn't know how to fix it... And the volume on my Nav system goes very low and when I try to turn it up the radio comes on?? Please don't let this beautiful auto be a 🍋!
 

·
Registered
Joined
·
1 Posts
I am also having the same issue. My clock is 4 hours ahead. The "Manual time adjustment" is grayed out. Occasionally my radio station presets change then the next time I use the car they are back.
Did you have the wireless car play upgrade?
I have the exact same issue, both with the clock and radio presets. I got a software update, which fixed the clock issue for 3 weeks, but then it jumped ahead 4 hours. My dealership said Infiniti is aware of the problem, but no fix yet. Pretty frustrating, especially when one of options for the top screen is to show the clock.
 
1 - 9 of 9 Posts
Top