Infiniti QX50 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
I just ran into an odd failure on my 2016 QX50. It started spotting coolant in the garage, and was difficult to trace back where it was coming from, as it puddled in the splash guard tray and tricked out nowhere near the leak.

Tracked the leak down to a heater hose, and then realized how the heater hoses were buried between the engine and firewall. After some judicious research, and realization that this wasn't a 30 minute repair, I broke down and hired it out. Went ahead and replaced both hoses, with all associated hardware.

Seemed like a strange failure, as I only have 56K on the vehicle, and I have two other vehicles with MANY more miles, and no hint of hose failure :unsure:.

Anybody else had these hidden hoses fail?
 

·
Registered
Joined
·
19 Posts
I just ran into an odd failure on my 2016 QX50. It started spotting coolant in the garage, and was difficult to trace back where it was coming from, as it puddled in the splash guard tray and tricked out nowhere near the leak.

Tracked the leak down to a heater hose, and then realized how the heater hoses were buried between the engine and firewall. After some judicious research, and realization that this wasn't a 30 minute repair, I broke down and hired it out. Went ahead and replaced both hoses, with all associated hardware.

Seemed like a strange failure, as I only have 56K on the vehicle, and I have two other vehicles with MANY more miles, and no hint of hose failure :unsure:.

Anybody else had these hidden hoses fail?
We’ll I have 2019 QX50 with 72,400 miles no issue yet I hope it stays like that I do a lot expressway driving sum city driving also
 
1 - 3 of 3 Posts
Top